Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

WNAM полностью поддерживает работу в среде виртуализации (тестировано VMware ESXi 5.0 и выше). Не рекомендуется применить SPAN-агента в виртуальной инфраструктуре (высоки накладные расходы на проброс трафика), лучше установить агента на отдельный сервер. 

Для работы в отказоустойчивой (кластерной) конфигурации вам потребуется как минимум два сервера (физических или виртуальных), размещённых в одном сегменте ЛВС, либо в разных ЦОД в зависимости от выбранной схемы кластеризации. Для целей кворума кластера рекомендуется установить третий сервер (виртуальную машину с минимальной конфигурацией). Кластерная конфигурация WNAM лицензируется отдельно.

Приложение написано в платформо-независимом виде (100% Pure Java), поэтому работает везде, где может работать Java JDK. Протестирована работа среде Linux (Ubuntu, Debian, CentOS) под управлением Oracle и OpenJDK 1.8. Настоятельно рекомендуется использовать ОС Debian последней версии. Работа под управлением FreeBSD возможна, но не тестировалась. В продуктивной работе мы рекомендуем использовать ОС семейства Linux, работающие в виртуальном окружении VMware, так как подобные системы более надежны, их проще администрировать, делать резервные копии, масштабировать. Работа под Windows поддерживается в экспериментальном режиме в ознакомительных целях.

Вам необходимо настроить межсетевой экран на вашем сервере. Как минимум, разрешите доступ по порту TCP:80 к веб-серверу в приложением WNAM, а также ssh (TCP:22) для управления, UDP:1812 и UDP:1813  для работы с RADIUS-сервером (только с ваших, определенных сетей). Рекомендуется использовать HTTP-интерфейс. Подробнее список требуемых портов перечислен здесь.

Для версии WNAM 1.6 обязательными компонентами прикладного программного обеспечения являются:

  • Java runtime (JRE или JDK в виде Oracle Java или OpenJDK/JRE) версии 1.8 (не 9, 10 и так далее)
  • MongoDB 4.0 и выше 
  • Nginx 1.10 и выше 
  • PhantomJS 2.1.1

Для версии WNAM 1.3 и выше обязательными - 1.5 обязательными компонентами прикладного программного обеспечения являются:

  • Java runtime (JRE или JDK в виде Oracle Java или OpenJDK/JRE) версии 1.8 (не 9, 10 и так далее)
  • MongoDB 3.0 и выше (рекомендуется 3.6)
  • Nginx 1.10 и выше - если вы планируете использовать портал на порту TCP:80 и/или TCP:443
  • Apache Tomcat 8.5 - не требуется для WNAM 1.5 и выше
  • FreeRADIUS 2 или 3 - не обязательно для WNAM 1.5 и выше
  • Perl 5.10 и выше - не обязательно для WNAM 1.5 и выше
Помимо этого мы советуем установить на сервере следующие необязательные пакеты:
  • Kannel для отправки СМС-сообщений вашему провайдеру по протоколу SMPP
  • UniFi controller (http://www.ubnt.com/download) - если вы будете управлять точками доступа UniFi. 
  • DNS сервер (для абонентов Wi-Fi)
  • DHCP сервер (для абонентов Wi-Fi)
  • Zabbix (для мониторинга вашего сервера и сети)
  • ipt_netflow cflowd (для сбора статистики по трафику , если ваш сервер является роутером для абонентов)

...

  • NetFlow

...

  • )

...